Overo TidalStorm Windows CE

Jul 18, 2014 at 4:12 PM

I tried following the instructions for running windows from a uSD card, and I'm running into some issues. I have the FAT32 partition set up, and I have tried separately both CE6 and the newer release separately with no luck. I copied over the MLO file first, to a blank uSD card (after performing the FAT32 partition), then the other two files after that. When I place the uSD card in the slot on my Overo TidalStorm and attempt to boot, I get nothing from both the terminal emulator and the hdmi output.

Do the demo images not work with the 3730 processor? Alternatively, is the Overo TidalStorm incompatible? Or am I doing something incorrect in the setup?

Note: when I do the FAT32 partition, the uSD card comes up as "16GB file system", but upon opening it, is it absolutely empty. Is that correct? No files or folders or anything. I used the HP partitioning software. Just double-checking on that as I am unfamiliar with FAT32.

Thanks in advance.
Jul 18, 2014 at 7:24 PM

Yes, use the HP formatting tool from my site.

There are other version of the tool out there that do not work.

The partition has to be marked as ACTIVE which my version of the tool does.

Might also try another card. After formatting it should show up on PC as properly formatted drive with the correct storage space.


Jul 18, 2014 at 7:39 PM
Thanks so much for your response; I will give it a try.

Excuse my incompetence, but could you direct me towards that tool on your site? I'm having trouble finding it.
Jul 18, 2014 at 8:02 PM

Should be included in the download file else you can down load from the “source code” directory


Jul 21, 2014 at 2:54 PM
I tried using that version of the formatting tool, and still got no result.

Just to be clear, these are the steps I'm taking: 1.) format 16GB uSD card with FAT32 using your tool and 2.) extract MLO file to 16GB filesystem first, then the other two files (NK.bin and ebootSD.nb0). I then place the uSD card in the slot on the gumstix, connect it to HyperTerminal, and connect the power.

All that appears in hyperterminal is the "@" character as soon as I connect the power. With the Linux uSD card, it works properly.

Lastly, there should be no folders on the uSD card or anything, correct? The partitioning doesn't add any sort of organization system?

Thanks again for your help.
Jul 21, 2014 at 3:13 PM

That should work. You might try a smaller card ..like a 2Gb or smaller.

Do have a module with on board flash?


Jul 21, 2014 at 7:34 PM
Unfortunately I do not.

I was thinking about using the 8GB high-speed uSD card that came pre-packaged with Linux, but I dont want overwrite and risk losing anything. I'll look into trying another uSD card, then.
Jul 21, 2014 at 8:02 PM
Now I get it to boot, but the display screen reads "Special Computing Please Wait..." with a progress bar on the bottom. Once the progress bar fills up completely, nothing happens. Does this make any sense to you?
Jul 22, 2014 at 5:15 PM
Getting warmer.

Now, the boot starts up and the green progress bar is completely full. However, it hangs there indefinitely. I looked through the output on hyperterminal for an answer, but can't discern what it means.

One error I receive says "OMAPDisplayController Failed to Request pads." Another one says something about an error on line 300 in some file that end in dssai.cpp. Lastly, it says Exception: Data Abort.

Does this have relevance? it looks to me as if the bootup is hanging for some reason, and I can't understand why. Do you think it has to do with my uSD card? The card that the Linux image is an 8GB high-speed uSD card whereas this is 16GB and not high-speed.

Thanks again.